User permissions

Oct 27, 2014 at 3:44 PM
I've got this working fine under my admin account but users only see the rotating dots in the multi-select field on the form. I've looked at the security roles but must be missing some permissions. Can anyone give some guidance on what permissions need to be set?
Thanks
Mark
Coordinator
Oct 31, 2014 at 6:08 PM
Hi Mark,

You can check the permissions you need just using common approach associating the records between 2 entities having N:N relationship.
Most likely that the user needs Read and Append To permissions for the related entity. Also maybe you have met the issue in the rollup 2 (2013). Here is some discussion: https://community.dynamics.com/crm/f/117/t/119729.aspx
Please let me know if it doesn't help.
Thanks
Pavel
Nov 6, 2014 at 1:04 PM
Hi Pavel,
Thanks for your response. I have given the user's Security Role practically full rights on the related entity but the problem still remains. We are using CRM 2011 Rollup 16. Any help on diagnosing the problem would be appreciated.
Thanks
Mark
Coordinator
Nov 10, 2014 at 5:15 PM
Edited Nov 10, 2014 at 5:16 PM
Hi Mark,
Please verify if you have the Role=>Customization=>Relationship privilege checked (read mode).
If it doesn't help, please find me in skype: khorozhansky
Thanks
Pavel
Nov 11, 2014 at 8:40 AM
Hi Pavel,
Thanks for the suggestion but the Role=>Customization=>Relationship privilege was already set to Read. Thanks for your Skype id. Really appreciate that. I'll try to contact you next time I'm in the office.
Mark
Nov 17, 2014 at 5:33 PM
Hi Pavel,
I logged in as the user without Admin permissions and tried the link: http://crmserver/deploymentname/WebResources/tunecrm_TuneCrmTools/xml/TuneMultiCheckBox/config.xml and got a 500 error with this result:

0x80041D1F Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: The user Id is invalid.Detail: <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts"> <ErrorCode>-2147214049</ErrorCode> <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" /> <Message>The user Id is invalid.</Message> <Timestamp>2014-11-17T16:53:59.6915998Z</Timestamp> <InnerFault i:nil="true" /> <TraceText i:nil="true" /> </OrganizationServiceFault> Business Management Error The user ID associated with the current record is not valid. The user ID associated with the current record is not valid. The user Id is invalid. Not available Not available The user Id is invalid. http://crmserver/deploymentname/Handlers/WebResource.ashx?name=tunecrm_TuneCrmTools/xml/TuneMultiCheckBox/config.xml /CRM/Handlers/WebResource.ashx?name=tunecrm_TuneCrmTools/xml/TuneMultiCheckBox/config.xml ASHX_XML

I've now realised that my normal users need READ permission on Solutions.

So problem solved. Sorry to miss that: might be worth adding to the guide, which is otherwise excellent.

Regards
Mark